Admin tool submission queue delayed
Incident Report for Crossref
Resolved
We were able to process the vast majority of the backlog of submissions in the admin tool deposit queue over the last few days. We're still seeing high volumes of submissions, which are resulting in some minor delays, but we've made progress processing submissions in the queue.
Posted Feb 10, 2021 - 15:40 UTC
Investigating
We're experiencing system instability as a result of internal software upgrades earlier in the week - https://0-status-crossref-org.library.alliant.edu/incidents/j9325lfr82sf. This has caused delays in submission processing in the admin tool (doi.crossref.org). We're working to get those existing submissions processed as soon as possible.
Posted Feb 05, 2021 - 14:05 UTC
This incident affected: Content Registration (Admin tool).